TRJS T R J S 0.7.5 - Documentation : Premiers pas

Comment installer TRJS


Condition pour l'installation

  1. Avoir une version de votre système d'exploitation compatible:
    • Mac OS :
      • version minimum 10.9 (Mavericks)
      • et plus récentes
      • Pour de plus anciennes versions, utiliser la version 0.4.9 de TRJS.
    • Windows :
      • Seven
      • 8
      • 10
    • Autres systèmes :
      • Linux: l'installation se fait à partir des sources.

Le programme d'installation est téléchargeable sur la page Téléchargement.

Sous Windows

  1. Cliquez sur le lien de téléchargement.
    Choisissez la version de Windows désirée: 64 bits (recommandée) ou 32 bits.
    Vous pouvez Enregistrer le fichier.
  2. Dans le dossier Téléchargements, vous trouverez le répertoire d'installation au format exécutable, nommé selon la version trjs-....exe.
    Veuillez l'ouvrir pour lancer l'installation.
    La fenêtre suivante apparaît: shorcuts Il est conseillé de garder cochée la case Desktop Shortcuts afin de pouvoir lancer le logiciel directement depuis le Bureau (Desktop) via un raccourci. emplacement Le répertoire par défaut est trjs dans "Program Files ..."
  3. L'installation de TRJS est terminée. Vous pouvez fermer.fin installation

Sous Mac OS X

Le téléchargement consiste en un fichier ZIP. Ce fichier peut être décompressé sur OSX, soit automatiquement, soit manuellement en faisant double-clic dessus(selon vos paramètres de navigateur). Une fois décompressée, l'application peut être déplacée où vous voulez, par exemple dans le dossier Applications, mais aussi dans un autre dossier.

Autres systèmes (linux, installation avec les sources)

Pour les systèmes Linux ou autres systèmes, installer à partir des sources et faire une installation séparée de Java (pour les outils d'export) et de FFMPEG pour visualiser le signal et utiliser les outils de conversion de fichier média.

Les sources sont disponibles ici: http://www.github.com/christopheparisse/trjs/ ou avec

    git clone http://www.github.com/christopheparisse/trjs.git
    
Attention: cette installation nécessite des préalables. Notamment, l'installation séparée de Node.js, NPM, Java, FFMPEG et FFPASTE. Il faut aussi ajouter des bibliothèques systèmes si elles ne sont pas présentes: sudo apt-get install libxext-dev libxtst-dev libxkbfile-dev Il est donc possible de faire les commandes suivantes:
    sudo apt-get update
    sudo apt-get install nodejs npm
    sudo apt-get install libxext-dev libxtst-dev libxkbfile-dev
    sudo apt-get install ffmpeg
    

Une fois l'archive décompressée ou récupérée avec git clone, aller dans le répertoire créé et faire:
    npm install
    npm run gulp
    
Le correcteur lexical doit être bien installé pour fonctionner et de fermer normalement le programme. Pour cela faire au moins une fois:
npm run rebuild
Pour lancer le programme une fois installé, il suffit de faire:
    npm run electron
    
Lancer la commande sh buildlinux.sh va créer un répertoire nommé release qui contient un répertoire nommé Trjs-linux-x64
. Ce dernier répertoire peut être déplacé et renommé. Il contient la command exécutable et tous les paramètres. Il suffit de lancer le fichier de nom "Trjs" dans ce dossier pour lancer TRJS. Si le Trjs-linux-x64 est déplacé, le répertoire contenant les sources peut être effacé. Sinon il peut être conservé pour les mises à jour futures. Pour ce faire, remplacer git clone par la commande git pull origin et répéter le processus.

Organisation et description de TRJS


Lancer TRJS

Il suffit de faire double-clic sur l'icone du programme.

Il est possible d'associer le programme à un type de fichier. Dans ce cas, il est conseillé d'utiliser l'extension .trjs pour les noms de fichiers pour éviter la confusion avec les fichiers d'extension .xml. L'utilisation de l'extension .xml ou .tei_corpo.xml reste tout à fait autorisée.

Présentation de la fenêtre TRJS

Après avoir lancé TRJS, le programme s'ouvre sur la fenêtre principale.
Cette fenêtre s'articule en différentes parties, comme découpées ci-dessous: TRJS image

  1. La barre de menus, avec accès aux paramètres et fonctionnalités.
  2. Le champ média, encadré des barres d'outils pour l'édition de la transcription.
  3. Le signal, représentation sonore du média.
  4. La partition, représentation horizontale de la transcription.
  5. Les commandes média, boutons de lecture et d'édition de la transcription.
  6. La transcription, où on peut éditer notre texte.
  7. Fenetres d'outils d'accès rapide.

La barre de menu comprend les sous-menus déroulant suivants :

L'onglet Ficher propose plusieurs options d'ouverture, de sauvegarde et d'import.
L'onglet Edition permet d'éditer les métadonnées liées au(x) fichier(s) transcription et média.
L'onglet Outils donne accès aux paramètres (affichage, réglages etc.), à des options de conversion, d'export, de correction du(des) fichier(s).
L'onglet View de zoomer, d'afficher ou cacher les barres d'outils.
L'onglet Aide contient les liens vers les sites de documentation et mémos.

En cliquant sur le menu FICHIERS (en haut à gauche de l'écran), l'encart déroulant propose plusieurs options :

  1. Ouvrir une transcription, pour ouvrir une trancription existante.
  2. Choisir un média, parmi un média existant.
  3. Nouvelle transcription, pour créer une transcription.
  4. Nouvelle fenêtre, pour ouvrir une seconde fenêtre pour la même transcription.
  5. Enregistrer, pour sauvegarder votre travail existant.
  6. Enregistrer sous... pour une sauvegarde dans votre environnement de travail.
  7. Sauver dans le cache, afin de retrouver votre travail via votre navigateur.
  8. Fermer la fenêtre actuellement affichée.
  9. La liste des derniers fichiers ouverts, les derniers fichiers que vous avez modifiés peuvent être rappelés.
  10. Export, un outil pour exporter son travail vers plusieurs formats cibles.

Outils d'édition proposés par TRJS

  1. Insérer une ligne dans la transcription
  2. Supprimer une ligne dans la transcription
  3. Insérer une macro
  4. Annuler, l'action précédente.
  5. Liste des annulations, déploie une fenêtre qui liste l'historique des dernières actions réalisées. Ainsi, il est possible de revenir à l'étape précédente.
  6. Refaire, la dernière action annulée.
  7. Fonctions de copier coller pouvant être utilisées dans une ligne.
  8. Les options d'édition pour la sélection multiple, sélection définie par le transcripteur d'un ou plusieurs extrait(s) de la transcription globale :
    • Afficher ou cacher la sélection multiple
    • Sélectionner ou désélectionner la sélection multiple
    • Couper la sélection
    • Copier la sélection
    • Coller

Plusieurs outils sont proposés par TRJS

    Menu Recherche: Une fenêtre s'ouvre, avec 4 encarts:

    1. Recherche
    2. Recherche-Remplace
    3. Affichage
    4. Aller à...
  1. Tiers (métadonnées pour l'organisation de la transcription).
  2. Autres
    • Métadonnées concernant l'ensemble de la transcription
    • Données concernant les locuteurs
  3. Accès aux macros
  4. L'accès aux paramètres : (une fenêtre se déploie, elle contient plusieurs encarts aux fonctionnalités thématiques.)
  5. Une Vérification de la transcription
  6. Un Décalage des repères temporels
  7. Un Outil de conversion

  1. Passer en mode plein écran ou revenir en mode fenêtre
  2. Zoom: agrandir ou rétrécir la police utilisée sur toute la page, ou revenir à la taille standard.
  3. Minimiser la fenêtre ou la fermer.
  4. Afficher ou non les barres d'outils
  5. Afficher ou non les outils développeur de l'application.

Les sous-menus contiennent :

  1. MacOs seulement: recherche d'aide dans le système MacOS
  2. Aides rapides (s'affichent sous forme de petites fenêtres séparées
    • Start / open a transcription
    • Transcribing new data
    • Edit a previous transcription
    • Paramètres
  3. Aide complète (site : http://ct3.ortolang.fr/trjs/doku.php)
  4. Aide rapide en anglais
  5. Aide rapide en français
  6. Liste des fonctions du clavier - Visualisation et édition des raccourcis claviers et leurs fonctions
  7. Message - Historique des messages affichés
  8. Remise à zéro des messages affichés
  9. A propos de TRJS - Informations complémentaires et droits

Champ média

Le champ média contient la vidéo et/ou l'audio.





La barre de lecture est propre au média (et dépendante du navigateur utilisé), elle apparaît lorsqu'on passe le curseur sur le média, puis disparaît après 3 secondes.
Elle offre les options suivantes :

  1. Revenir en arrière (3 secondes par défaut : valeur modifiable dans le menu PARAMETRES ) ou raccourci clavier : Alt ←
  2. Lecture simple/pause
  3. Barre de déplacement horizontal dans le média, avec position indiquée en hh:mm:ss
  4. Affichage du temps complet du média
  5. Volume (option muet)
  6. Plein écran ou raccourci clavier : ESC pour revenir à une taille miniature
  7. Sauter en avant ou raccourci clavier : Alt →

Le média est encadré par des barres d'outils (8).

Il existe des raccourcis clavier (cf. Barres d'outils) pour :

Concernant les liens entre média et transcription :

  • La zone média est en mode standard par défaut.
  • En mode bloqué, elle positionne la transcription.
  • Des raccourcis clavier sont ajoutés pour lancer directement la synchronisation en mode bloqué entre média et transcription :
    • Lecture de la ligne courante : F7
    • Lecture continue (à partir de la ligne courante) : F8

Pour plus de détails, consulter les fonctions de lecture et barres d'outils.

Signal

Le signal est une représentation sonore du média dans son intensité (densité d'énergie acoustique) en fonction du temps en secondes et de la fréquence en Hertz.



Concernant les liens entre signal et transcription :

Partition

La partition est une représentation horizontale de la transcription (verticale) qui permet de visualiser intuitivement les chevauchements des tours de parole des locuteurs.



Visualisation

Les encarts qui s’affichent en vert sont les encarts sélectionnés ou en cours de lecture.

Slider partition

La barre jaune (située en-dessous de la partition) est la barre de défilement horizontal de la partition :

Boutons média

Autour du champ média (audio ou vidéo) sont déployés des boutons, associés à des raccourcis claviers.



Lorsqu'on passe la souris sur une icône, une bulle d'information apparaît pour rappeler la fonction principale de l'icône, ainsi que son raccourci clavier associé.


Icône Raccourci clavier Fonctionnalité
Play/Pause : lecture simple (à partir de l'endroit où le curseur est situé)
/!\ Cette fonction de lecture ne déplace pas le curseur positionné dans le tableau de transcription.
Set start : insertion dans la transcription du temps de début d'un segment à transcrire (à l'endroit où le curseur est situé dans le tableau de transcription)
Set end : insertion dans la transcription du temps de fin
Insert : insertion d'une ligne vide sous un locuteur dans la transcription
Repeat : lecture de la ligne courante (où se situe le curseur dans la transcription)
Go continuous : lecture continue (à partir de l'endroit où se situe le curseur)
Backward : recule (déplacement de une image, de une seconde, à l'extrémité de la partition)
Forward : avance
  Zoom : L'option zoom permet d'agrandir ou de rétrécir la visualisation du signal et de la partition et ce jusqu'à 2,6 secondes.

Transcription

La transcription orthographique du signal est éditée sous forme de tableau déroulable (la barre de défilement vertical se trouve sur la droite).
Le tableau de transcription est une visualisation verticale éditable du texte.




Barres d'outils



Les barres d'outils permettent d'accéder très rapidement aux principales commandes d'édition.
Chaque icône est également définie par un raccourci clavier, qui s'affiche au moyen d'une infobulle lorsqu'on passe la souris par dessus.
On peut rétrécir ou déplacer les barres d'outils.

Ouvrir une transcription


Créer une nouvelle transcription

Dans le menu FICHIERS , sélectionner Nouvelle transcription.


Une fenêtre s'ouvre alors pour vous demander de choisir le fichier média associé (audio ou vidéo). Vous pouvez choisir un média ou annuler pour travailler sans média, puis vous pouvez commencer la transcription.


La partie transcription est désormais éditable à l'endroit indiqué.


Ouvrir une transcription existante

Dans le menu FICHIERS , sélectionner Ouvrir une transcription.


La transcription est chargée, mais vous n'avez pas de fichier média, comme indiqué.




Allez à la partie ci-dessous "Lire un média".

Lire un média


Charger un média

Dans le menu FICHIERS , sélectionner Choisir un média.

Si tout s'est déroulé sans encombre, le média est chargé.
Sinon, un message d'erreur vous avertit d'un éventuel problème de compatibilité avec le format média. Dans ce cas il pourra être nécessaire de faire une conversion.

Gestion du média

Fonctions de lecture

Plusieurs commandes et boutons de lecture du média sont disponibles, chacun a des fonctionnalités et des champs d'actions spécifiques :

Icône ou raccourci clavier Fonctionnalité Description
TAB Lecture à partir du point d'arrêt si dans la ligne courante ou sinon à partir du début de la ligne courante, pause
Shift + F1 Lecture à partir du média, pause
Shift + TAB Lecture à partir du début de la ligne courante permet de relire en boucle à partir du même endroit
F7 Lecture de la ligne courante segment temporel seulement
Alt F7 Lecture de 3 lignes autour de la ligne courante permet d'isoler un contexte
F8 Lecture continue à partir de la ligne courante

Edition de la transcription


Structure de la transcription

La transcription orthographique du signal est éditée sous forme de tableau déroulable (la barre de défilement vertical se trouve sur la droite).
Le tableau de transcription est une visualisation verticale éditable du texte.



Le tableau de trancription est divisé en quatre colonnes :

  1. Locuteur - Ce champ renseigne l'identifiant du locuteur ou l'identifiant de la structure de ligne (dépendante du locuteur).
    • Chaque nouveau locuteur doit être renseigné dans le tableau des participants
    • Chaque nouvelle valeur de structure doit être renseignée dans le tableau des structures
    • Visuellement, les structures supplémentaires s’imbriquent sous le locuteur (qui est la ligne principale par défaut)
  2. Start - le temps de début et
  3. End - le temps de fin
    • Un clic permet d'obtenir le temps en millisecondes (par défaut)
    • L'affichage du nombre et du format pour les millisecondes est modifiable dans le menu paramètres.
  4. Transcription - la partie texte éditable
    • Les nuances de gris sur les lignes correspondent aux locuteurs, il y a 3 nuances du gris foncé au blanc: plus le gris est foncé, plus la fréquence du temps de parole du locuteur est élevée.
    • La ligne sélectionnée est surlignée en bleu (en bleu clair pour une ligne dépendante)

Le positionnement sur une zone transcrite positionne la partition (si possible c'est à dire si la transcription est liée temporellement) et le temps du média.

Edition des métadonnées

Un clic sur le nom du fichier (encart bleu) situé en haut, dans la barre de menu, permet d'éditer les métadonnées.

On accède également au tableau d'édition des métadonnées en passant par le menu EDITION puis Métadonnées.


Le tableau s'affiche pour l'édition, et se ferme à l'aide de la croix grise située en haut à droite.
Chaque ligne éditée du tableau s'enregistre automatiquement. Seules les parties grisées sont éditables.
Ces champs permettent de rentrer les informations générales sur le document y compris sur les noms de fichiers, mais aussi de rentrer les informations sur les champs métadonnées Dublin-Core.
Pour obtenir des informations supplémentaires, passez votre souris sur la partie Information située à droite du tableau, une infobulle apparaît.

Pour se déplacer :

Edition des locuteurs

Un clic droit sur le locuteur (colonne de droite) dans le tableau de transcription, permet de choisir le nom du locuteur ou la valeur de la tier à définir pour la ligne courante.

Une fois le clic droit activé dans le champ Locuteur (Locutor), un encart s'affiche proposant :

Ces valeurs sont des raccourcis vers les valeurs autorisées dans les entêtes de fichier, renseignées au préalable.
Si le code choisi n'est pas défini dans les noms de personnes ou tiers autorisés, le logiciel vous demande de changer la valeur et insère la valeur neutre "---".

Voir Paramètres d'édition des locuteurs pour insérer ou modifier les valeurs.

Pour définir et renseigner un nouveau participant, sélectionner dans le menu EDITION , l'onglet Participants.
Tout un ensemble de champs complémentaires est disponible pour fournir des informations sur un locuteur.

Il est également possible d'inscrire directement un locuteur ou une tier enregistré au préalable à l'aide d'un raccourci clavier :

Raccourcis clavier Codage direct du locuteur
Ctrl + 1 premier locuteur
Ctrl + 2 deuxième locuteur
... ...
Ctrl + 9 neuvième locuteur
Codage direct du tier (champ décrivant un énoncé)
Ctrl + Alt + 1 première propriété des templates (tiers secondaires)
Ctrl + Alt + 2 deuxième propriété
... ...
Ctrl + Alt + 9 neuvième propriété

Edition des valeurs temporelles

Dans le tableau de transcription, il est possible d'éditer les valeurs temporelles de début et de fin en double cliquant sur la valeur à modifier.
Un simple clic permet de visualiser le nombre de millisecondes.

Il est possible de paramétrer le format d'affichage des données temporelles dans le menu PARAMETRES :

Le chiffre de millisecondes à afficher est modifiable (de 0 à 3). Par défaut, on affiche 0 millisecondes.

Enregistrer la transcription (formats et conversions)

Vous pouvez à tout moment sauvegarder la transcription en cours :

Vous pouvez définir ou modifier l'emplacement de votre fichier de transcription en accédant à l'encart Enregistrer sous... du menu FICHIERS , et ainsi renommer votre fichier.

Les options d'exports sont disponibles dans le menu OUTILS sous l'onglet Export.
Il est possible d'exporter la totalité du fichier ou seulement une sélection.

Méthodes de transcription


Usages de transcription et commandes d'édition

La touche Enter/Return fonctionne de la manière suivante :

Cette touche permet de réaligner des lignes déjà transcrites, son usage est principalement réservé au réajustement du temps d'un fichier déja transcrit.

La touche Return/Entrée correspond au raccourci clavier : Ctrl + M, accessible via l'icône de la barre d'outils.


Certaines touches du clavier sont destinées à marquer les alignements temporels dans le tableau de transcription :

Raccourcis clavier Commandes d'édition
Return (Entrée) Fonction de remplacement (ou Ctrl + M), alignement de la fin de l'énoncé avec le temps courant puis saut à la ligne suivante; si on est en fin de fichier, alors insertion d'une ligne (ceci permet de réaligner des lignes déjà transcrites).
F4 Alignement du début de l'énoncé avec le temps courant
F5 Alignement de la fin de l'énoncé avec le temps courant
F6 Création (insertion) d'une nouvelle ligne sous le curseur sans insérer d'élément temporel ni de locuteur
Alt + F6 Insérer une ligne vide sous un locuteur en notant le temps courant
Ctrl + I Insérer une ligne vide
Ctrl + Alt + I Insérer une ligne vide avec le temps courant
Ctrl + M Marquer le temps de la fin de la ligne courante principale et le temps de début de la suivante et sauter à la ligne suivante
Ctrl + Alt + M Marquer le temps de la fin de la ligne courante et le temps de début de la suivante
Ctrl + T Aller au repère temporel

Commandes d'annulation

Annuler la dernère action

La commande d'annulation (undo) annule la dernière action au moyen du raccourci clavier Ctrl Z.

Historique des dernières actions

En ouvrant le menu EDITION , puis Undo, on a accès à l'historique des dernières actions réalisées.

Reproduire la dernière action

Pour reproduire la dernière action (redo), le raccourci clavier est Ctrl Y.

Manipulation du clavier


Commandes d'édition

TRJS est prévu pour la transcription et l'alignement rapide, et la manipulation intuitive de la vidéo/du son. Il est optimisé pour être utilisé facilement (et complètement) depuis le clavier, sans nécessité d'utiliser la souris.

Commandes d'édition principales

Raccourci clavier Fonctionnalité
Commandes de lecture : Certaines touches du clavier sont destinées à manipuler le média
F1 Lecture simple et pause
Tab Lecture à partir du début de la ligne courante, pause (ou tabulation)
Alt + F1 Lecture à partir de l'endroit où le curseur est situé, pause
Shift + Tab Lecture à partir du média, pause
Shift + F1 Lecture à partir du début de la ligne courante
Escape Pause
Alt + ←
(ou F2)
Revenir en arrière (3 secondes par défaut)
(La valeur de retour en arrière ou de saut en avant est modifiable dans le tableau des paramètres.)
Alt + →
(ou F3)
Sauter en avant
Alt + F2 Agrandir la vidéo
Alt + F3 Rétrécir la vidéo
Alt + F4
(ou Ctrl + B)
Jouer la vidéo moins vite
Alt + F5
(ou Ctrl + E)
Jouer la vidéo plus vite
F7 Lecture de la ligne courante (où se situe le curseur dans la transcription)
Alt + F7 Lecture de la ligne courante, la ligne précédente et la suivante (3 lignes principales)
F8 Lecture continue (à partir de l'endroit où se situe le curseur)
Commandes d'édition : Certaines touches du clavier sont destinées à marquer les alignements temporels dans le tableau de transcription
Return (Entrée) Si Return est en mode Remplacement (par défaut, ou Ctrl + M), alignement de la fin de l'énoncé avec le temps courant puis saut à la ligne suivante; si on est en fin de fichier, alors insertion d'une ligne (ce mode permet de réaligner des lignes déjà transcrites).
Si Return est en mode Insertion (ou Alt + F6), insertion d'une ligne et notation du temps courant
(Le comportement de Return peut être modifié dans le tableau des paramètres.)
F4 Alignement du début de l'énoncé avec le temps courant
F5 Alignement de la fin de l'énoncé avec le temps courant
F6 Création (insertion) d'une nouvelle ligne sous le curseur sans insérer d'élément temporel ni de locuteur
Alt + F6 Insérer une ligne vide sous un locuteur en notant le temps courant

Edition par raccourcis des locuteurs et autres tiers

Raccourcis clavier Codage direct du locuteur
Ctrl + 1 Premier locuteur
Ctrl + 2 Deuxième locuteur
... ...
Ctrl + 9 Neuvième locuteur
Codage direct du tier (champ décrivant un énoncé)
Ctrl + Alt + 1 Première propriété des templates (tiers secondaires)
Ctrl + Alt + 2 Deuxième propriété
... ...
Ctrl + Alt + 9 Neuvième propriété

Commandes d'édition spécifiques

Raccourci clavier Fonctionnalité
Commandes d'édition classiques
Ctrl + O Ouvrir un fichier
Ctrl + Alt + O Charger un média
Ctrl + S Sauvegarder
Ctrl + F Lancer une recherche
Ctrl + A Tout sélectionnner
Ctrl + Y Reproduire la dernière action
Ctrl + Z Annuler la dernière action
Commandes de déplacement
Ctrl + L Aller à un numéro de ligne
Aller à la ligne précédente
Aller à la ligne suivante
Alt + ↑ Aller à la ligne principale précédente
Alt + ↓ Aller à la ligne principale suivante
Page haut Aller en haut de la page
Page bas Aller en bas de la page
Ctrl + Home Aller au début du fichier
Ctrl + End Aller à la fin du fichier
Commandes d'édition des alignements temporels
Ctrl + I Insérer une ligne vide
Ctrl + Alt + I Insérer une ligne vide avec le temps courant
Ctrl + M Marquer le temps de la fin de la ligne courante principale et le temps de début de la suivante et sauter à la ligne suivante
Ctrl + Alt + M marquer le temps de la fin de la ligne courante et le temps de début de la suivante
Commandes d'édition de la transcription
Ctrl + D Supprimer une ligne
Ctrl + Alt + D Supprimer une ligne et tous les tiers qui en dépendent
Ctrl + J Joindre deux lignes (ligne courante et la suivante)
Ctrl + Alt + J Joindre deux lignes sous un même locuteur
Ctrl + R Dupliquer une ligne
Ctrl + Alt + R Scinder une ligne en deux (à l'endroit où se trouve le curseur) sans indication temporelle
Divisions du texte
Ctrl + G Créer une division du texte (séquence ou saynète)
Ctrl + Alt + G Marquer la fin d'une division
Ctrl + Shift + G Fermer toutes les divisions ouvertes
Ctrl + U Cacher les divisions
Ctrl + Alt + U Montrer les divisions cachées
Ctrl + Shift + 1 Marquer la ligne courante comme début d'une division
Ctrl + Shift + 2 Marquer la ligne courante comme fin d'une division
Commandes média spécifiques
Ctrl + B
(ou Alt + F4)
Jouer le média plus lentement
Ctrl + E
(ou Alt + F5)
Jouer le média plus rapidemement
Ctrl + Alt + B Lecture à l'envers
Ctrl + Alt + E Lecture à un rythme normal

Insertion de caractères phonologiques

TRJS permet d'insérer des caracatères API (pour le codage phonologique).
En général, faire :

Raccourci clavier Correspondance API Description
Alt + A ɑ Voyelle basse postérieure non arrondie
Alt + E ɛ Voyelle moyenne inférieure antérieure non arrondie
Alt + O ɔ Voyelle moyenne inférieure postérieure arrondie
Alt + 9 œ Voyelle moyenne inférieure antérieure arrondie
Alt + 2 ø Voyelle moyenne supérieure antérieure arrondie
Alt + @ (ou Alt + 0) ə Schwa
Alt + R ʀ Consonne roulée uvulaire voisée
Alt + S ʃ Consonne fricative post-alvéolaire sourde
Alt + Z ʒ Consonne fricative post-alvéolaire voisée
Alt + H ɥ Consonne spirante labio-palatale voisée
Alt + J ɲ Consonne occlusive nasale palatale voisée
Alt + N ɳ Consonne occlusive nasale rétroflexe voisée
Alt + Shift + N ŋ Consonne occlusive nasale vélaire voisée
Alt + T θ Consonne fricative dentale sourde
Alt + D ð Consonne injective alvéolaire voisée
Alt + I ɪ Voyelle haute inférieure antérieure non arrondie
Alt + Q ɒ Voyelle basse postérieure arrondie
Alt + V ʌ Voyelle moyenne inférieure postérieure non arrondie
Alt + U ʊ Voyelle haute inférieure postérieure arrondie
Alt + X χ Consonne fricative uvulaire sourde
Alt + : ː Long
Alt + Shift + A ɑ̃ Voyelle nasale basse postérieure non arrondie
Alt + Shift + E ɛ Voyelle nasale moyenne inférieure antérieure non arrondie
Alt + Shift + 9 œ̃ Voyelle nasale moyenne inférieure antérieure arrondie
Alt + Shift + O ɔ̃ Voyelle nasale moyenne inférieure postérieure arrondie
Alt + Shift + Q æ Voyelle pré-ouverte antérieure non arrondie

Organisation et fonctionnalités


Paramètres

Dans le menu PARAMETRES , les paramètres suivants sont modifiables :

Paramètre Descriptif Localisation
Version Deux versions sont pour le moment disponibles : Français et Anglais Onglet LANGUE
Visualisation de la partition Coché par défaut Onglet AFFICHAGE
Visualisation du signal sonore Coché par défaut Onglet AFFICHAGE
Affichage des numéros en début de ligne Par défaut ils ne sont pas affichés Onglet AFFICHAGE
Affichage des noms des participants A la place des codes Onglet AFFICHAGE
Affichage des temps des alignements C'est-à-dire les temps de début et de fin, coché par défaut Onglet AFFICHAGE
Modes d'édition des zones d'affichage 3 modes sont disponibles : Libre, Contrôle (Standard), Bloqué Onglet MODES D'EDITION
Réorganisation dynamique des lignes Onglet MODES D'EDITION
Format pour les repères temporels Renseigné par défaut en h:mm:ss Onglet REGLAGES
Nombre de chiffres pour les millisecondes De 0 à 3 Onglet REGLAGES
Valeur de retour en arrière (Pour le raccourci clavier : ) en ms Onglet REGLAGES
Valeur de saut en avant (Pour le raccourci clavier : ) en ms Onglet REGLAGES
Vérification de la transcription lors de la sauvegarde Coché par défaut Onglet VERIFICATION
Nombre de versions précédentes conservées lors de la sauvergarde De 1 à 3 Onglet VERIFICATION

Lorsqu'on passe la souris sur un paramètre, une bulle d'information apparaît pour rappeler sa fonction principale, ainsi que son raccourci clavier éventuel associé.

Outil de recherche

L'onglet de recherche s'affiche sous forme de panneau. On y accède par plusieurs moyens :

Il est possible d'effectuer plusieurs types de recherche dans le fichier courant :

Haut de page